Как установить Postgresql 11.1 в Ubuntu Server 18.04


На самом деле, возможно это и к лучшему, так как бинарные инсталляторы от EDB были мягко говоря не обновляемыми и с патчами безопасности при таком подходе были проблемы. Однако, стоит отметить, что графический инсталлятор как в Windows делал свое дело и многие разработчики для своих рабочих станций выбирали именно такой вариант развертывания, так как в комплекте шло все необходимое окружение включая и PgAdmin 4 необходимый для графического администрирования баз данных PostgreSQL.

В статье "Установка Postgresql версии 10 в Ubuntu Linux и Debian Linux" я уже рассказывал о установке PostgreSQL версии 10 в Ubuntu и Debian Linux и теперь я расскажу про установку 11-ой версии в Ubuntu Linux.

Установку будем проводить в Ubuntu Server LTS 18.04, более старые версии Ubuntu Server уже не имеет смысл рассматривать. Кодовое имя Ubuntu Server 18.04 - Bionic Beaver. Как и в случае с рассматриваемым год назад Postgresql 10 устанавливаемым на Xenial ветке сводится к простой и типовой для Дистрибутивов Ubuntu Linux последовательности:

  • Подключаем репозиторий PostgreSQL
  • Обновляем список пакетов
  • Устанавливаем необходимое ПО

Для подключения репозитория с сервером баз данных PostgreSQL выполнить в консоли следующие команды:

# echo 'deb http://apt.postgresql.org/pub/repos/apt/ bionic-pgdg main' >> /etc/apt/sources.list.d/pgdg.list
# wget https://www.postgresql.org/media/keys/ACCC4CF8.asc
# sudo apt-key add ACCC4CF8.asc

Обратите внимание, что все операции я выполняю от имени супер-пользователя root. Если вы работаете под непривилегированным пользователем, то вам придется использовать команду sudo.

Как я уже сказал выше, следующим этапом обновляем список доступного для установки ПО:

# apt-get update

И переходим к финальному этапу, а именно установке Postgresql-сервера и PgAdmin4:

# aptitude install postgresql-client-11 postgresql-11 postgresql-server-dev-11
# aptitude install pgadmin4

Как вы видите установка PostgreSQL из репозитория не намного сложнее, чем из бинарного пакета EDB.